MokoMakefile now builds OM-2007.2 (Was: Balancing simplicity with complexity)

Jeff Rush jeff at
Fri Aug 24 18:21:56 CEST 2007

Rod Whitby wrote:
> The MokoMakefile (<>) has been
> updated to build OM-2007.2 images.
> If you're starting from scratch, just follow the instructions on that
> wiki page.  Pay careful attention to the host software package
> requirements for the OpenEmbedded build system.
> If you're migrating from a previous version of the MokoMakefile, then
> just type:
>   make update-makefile ; make setup update openmoko-devel-image

I'm hitting a build problem here.  I was previously able to build the
OM-2007.1 but wanted to switch to .2.  First I updated my old build env and
got the following error.  Then I blew it away and did a completely fresh
build, still with the same error.  This was last night, latest version
available.   The error is a missing patch file.

NOTE: Running task 181 of 3372 (ID: 1153,
/var/hostings/MOKO2/openembedded/packages/qemu/, do_patch)
NOTE: package qemu-native-0.9.0+cvs20070613: started
NOTE: package qemu-native-0.9.0+cvs20070613-r1: task do_patch: started
NOTE: Applying patch 'configure-0.9.0.patch'
NOTE: Task failed: Error:
not found.
NOTE: package qemu-native-0.9.0+cvs20070613-r1: task do_patch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package qemu-native-0.9.0+cvs20070613: failed
ERROR: Build of
do_patch failed
ERROR: Task 1153
do_patch) failed
NOTE: Tasks Summary: Attempted 180 tasks of which 0 didn't need to be rerun
and 1 failed.
'/var/hostings/MOKO2/openembedded/packages/qemu/' failed
make: *** [openmoko-devel-image] Error 1

I've run make setup update multiple times, same error.  It appears to be real.


More information about the openmoko-devel mailing list