Recipe for setting up OpenEmbedded environment on wiki

Phil Schaffner P.R.Schaffner at
Sat Feb 10 04:57:56 CET 2007

On Sat, 2007-02-10 at 10:26 +1030, Rod Whitby wrote:
> If you download a prebuilt .mtn file that was built with 0.32, then you
> need 0.32 to read it.
> If you get it over the network directly from scratch, or download a
> prebuilt .mtn file that was built with 0.27 (which is what
> distributes), then you can use anything from 0.27 to
> 0.32 to read it (and convert it if necessary).
> -- Rod
> Joe Pfeiffer wrote:
> > Rod Whitby writes:
> >> Monotone 0.28 is good enough (that's what I run on CentOS 4.4).
> >>
> >> The network protocol is compatible back to 0.27 (which is what
> >> is still running, cause it's running Debian Sarge).
> > 
> > It was not good enough on my Debian box.  0.31 gave me errors; iirc
> > something about an unkown revision in (though I'd have to
> > downgrade and redo to see just what the message was) right on the step
> > at that said
> > 
> >> If you run into a problem at this stage, check to make sure you have
> >> version 0.32 (or newer) of monotone installed.
> > 
> > Getting 0.32 fixed it.

The CentOS 4.4 story continues.  Locally built packages:

Built (with "$ rpmbuild --rebuild ...") from:
monotone-0.32-1.src.rpm (latest tarball + modified spec
  from monotone-0.31-2.fc7.src.rpm)

I put packages in a local repo so I can do "yum install ...", otherwise
can do "yum localinstall foo.1.2.3.noarch.rpm ...".

Appears I already had texi2html from the tetex package, as noted
elsewhere - don't know why yum failed to complain:

# rpm -qf /usr/bin/texi2html

So finally through step 1.2:
$ mtn --version
monotone 0.32 (base revision: 3f0fa5c1d232d37d47f6436fe74919dd3cd003b1)

On Fri, 2007-02-09 at 20:25 -0300, jeff wrote: 
> Rod Whitby wrote:
> > Phil Schaffner wrote:
> >> On Thu, 2007-02-08 at 13:17 -0800, Christopher Heiny wrote:
> >>> On Thursday 08 February 2007 07:42, picked up the following transmission 
> >>> from Christopher Heiny:
> >>>> That's a timely post!  My main system barfed Tuesday afternoon, and
> >>>> I've been bringing up a backup.  Here's some diffs to your procedure
> >>>> for Fedora Core 6...
> >>>>
> >>>> Under 1.1, I did
> >>>>    yum install ccache diffstate monotone
> >>>> since perl and python were already on the system
> >>> An update - texi2html and git should be added to that yum command:
> >>>     yum install ccache diffstate monotone texi2html git
> Might as well add `yum install texinfo python-psyco` while you are at it for FC6.

For step 1.3
[root at tabb1 ~]# rpm -q texinfo python-psyco


# yum install texinfo python-psyco

Up to step 2.2 (skipping 2.1 for now to go for a package):
Got bitbake-1.6.0-2.fc7.src.rpm from fedora-extras-development.
Required lynx as a build dependency, so add

# yum install lynx

to the recipe if not already in the mix, followed by

$ rpmbuild --rebuild bitbake-1.6.0-2.fc7.src.rpm

and (for a local repo or other pre-built source)

# yum install bitbake


# yum localinstall bitbake-1.6.0-2.noarch.rpm

2.3. Obtain OpenEmbedded - went exactly per the recipe.

3.1 Created /usr/local/openembedded/build/conf/local.conf per the
recipe, but bitbake is installed by the rpm package in

So guessing 3.2 should just be:


export \

to .bashrc

Wondering if contents of 3.1 shouldn't be added/exported there also. [?]

Did interactive exports of the environment variables of 3.1 and 3.2
before proceeding to 4.:

$ cd /usr/local/openembedded/build
$ time bitbake nano

Since this is the part that reportedly takes hours (particularly as I'm
running this on a vintage home-brew 1 Ghz K6 Athlon), will follow
Michael's example to the letter and check back in the morning.

OOPS - just checked on the build...

$ time bitbake nano
NOTE: Using cache in '/usr/local/openembedded/build/tmp/cache/ep93xx'
NOTE: Handling BitBake files: / (4164/4164) [100 %]
NOTE: Parsing finished. 78 cached, 3899 parsed, 187 skipped, 0 masked.

ERROR:  Openembedded's config sanity checker detected a potential
        Either fix the cause of this error or at your own risk disable
the checker (see sanity.conf).
        Following is the list of potential problems / advisories:

        Bitbake version 1.6.2 is required and version 1.6.0 was found

real    9m45.506s
user    9m14.031s
sys     0m17.796s

Apparently FC7/rawhide ported to CentOS is not quite bleeding-edge
enough for this project.  The saga will continue later - tomorrow,
time/wife/kids permitting.


More information about the openmoko-devel mailing list