MokoMakefile - type "make openmoko-devel-image" and you're done.

jeff moe at
Mon Feb 19 17:12:52 CET 2007

Rod Whitby wrote:
> I have created "MokoMakefile" - a fully automated way of setting up an
> OpenMoko development environment.

I have gotten this to work after a few hurdles. Hints:

404 error:

You need to do the things in

as MokoMakefile doesn't do them for you. In this case:
touch ../build/tmp/stamps/armv4t-linux/js-1.5-r0.do_fetch

dates_navigator.c:24:47: error: libedataserver/e-data-server-util.h: No such 
file or directory

Run this:
cd ${OMDIR} ; \
for fixrn in `find ./build/tmp/work ./build/tmp/staging ./sources -name 
e-util.h` ; do \
  THISDIR=`dirname ${fixrn}` ; \
cd ${THISDIR} && ln -s e-util.h e-data-server-util.h ;\
cd ${OMDIR} ; done

uboot-mkimage: command not found

I really don't remember how I solved this. ;)  Perhaps this hint:
<rwhitby> add ${STAGING_BINDIR}/ before it.

nand_read.c:57: error: ‘NAND_PAGE_SIZE’ undeclared (first use in this function)

IIRC, I just did this, which may have solved other issues as well:
make update-makefile ; rm -rf openmoko ; make setup update

That series of commands is a good set to use when things get messy and you want 
to start over.

error: expected specifier-qualifier-list before 'tsl_t'

This one just affects x86_64, AFAICT:

rm build/tmp/stamps/x86_64-linux/db3-native-3.2.9-r2.do_configure

patch this file: openembedded/site/x86_64-linux


rm ./build/tmp/stamps/armv4t-linux/eds-dbus-1.4.0*
cd build
. ../setup-env
bitbake eds-dbus


Hopefully this will be of some help to folks. I'm thinking of putting it on the 
MokoMakefile wiki talk page under =r1004=.  Si?

Thanks Rod for the Makefile. :)

-Jeff   /    #jebba

More information about the openmoko-devel mailing list