error while building with MokoMakefile: unparsed line

michael at michael at
Mon Feb 19 22:48:09 CET 2007

On Mon, 19 Feb 2007, Rod Whitby wrote:

> michael at wrote:
>> By 'bb' I presume we mean bitbake. I tried this - it needs to run in the
>> approprate directory because it presumes a conf file:
>>   bash-3.2$ bb -c clean
>>   bash: bb: command not found
>>   bash-3.2$ bitbake -c clean
>>   ERROR: Unable to open conf/bitbake.conf
>> So the question is what is the correct directory for this? I tried th
>> elinux-gta01 kernel directory mentioned above but still no
>> conf/bitbake.conf.
> Firstly, I presume that you have read the BitBake manual, and understand
> the layout of a OpenEmbedded build area.  If not, do so before continuing.
> You run bitbake commands in the build directory (as stated in the
> OpenMoko wiki page, which I also assume you've read carefully).
> -- Rod

Thanks. Yes, I've read all those documents. Trouble is I don't retain much of
what I read until I use it. Which is why I'm doing it now.

Anyway, your suggestion (in a different email) of

       make update-makefile ; rm -rf openmoko ; make setup update

worked. I've made it past that point.

Thanks again for the makefile and the assistance.


More information about the openmoko-devel mailing list