Request for Guided Walkthrough for configuring OpenEmbedded

Scott Oberg scottoberg at
Fri Jan 26 22:49:40 CET 2007

Hash: SHA1

Jonathon Suggs wrote:
> Yeah, I went through those pretty extensively.
> I'm running Ubuntu edgy (6.10).  I'm at work now, but I was having
> troubles getting monotone to work.  The dpkg was showing that it was
> installed, but I couldn't find any trace of it...and the following
> command from the GettingStarted page failed saying mtn wasn't recognized
> (or something similar)
Sounds like maybe the DB format you pulled is newer than your mtn
install?  Can't tell without the exact error.  I'm running on FC5 with
the following versions (and it looks like the last time I pulled the DB
was ~ 14th).

$ ls -la /oedev/
- -rw-rw-r-- 1 soberg soberg 121610240 Jan 14 04:37 /oedev/
$ mtn --version
monotone 0.32 (base revision: 3f0fa5c1d232d37d47f6436fe74919dd3cd003b1)
$ bitbake --version
BitBake Build Tool Core version 1.6.3, bitbake version 1.6.3


> mtn --db=/stuff/ pull 
> Note: Directory was changed appropriately.  
> I just noticed this statement on the website: Still OK with Edgy (Ubuntu
> 6.10) but monotone version installed this way is pretty old and I had to
> install from .deb present on monotone web site (dpkg -i xxx.deb).  I'll
> try that when I get home.
> Any other thoughts?  I thought the documentation seemed pretty
> straightforward too until I ended up at a dead end.  Oh well.  I'll get it.
> Scott Oberg wrote:
>> Hi Jonathon,
>> I take it that you've worked through the OE wiki pages?  They are quite
>> thorough.  A lot has been added just in the last couple months since I
>> first started building images and packages, and I used them again
>> recently after upgrading monotone, bitbake, etc.  The GettingStarted
>> page has examples for each step, which I consider a guided walkthrough.
>> If you are still stuck, I might recommend trying a distro that is easy
>> to upgrade to the 'right' dependencies, and then let us know about a
>> specific problem.
>> FYI - There is a temporary openmoko wiki here:
>> Scott
>> Jonathon Suggs wrote:
>>> I worked through trying to get a development environment up and running
>>> and encountered some problems.  So, could someone who was successful
>>> mind writing up a more detailed process.  I would be more than happy to
>>> update and edit it once I get myself going.
>>> I know we are still a ways out, but hopefully we can have a pretty
>>> streamlined process in place.  The last thing we want is potential
>>> developers to be frustrated before they even get started (I know I was
>>> last night...).
>>> -Jonathon
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-devel mailing list