Bitbake error: C compiler cannot create executables

Greg lunved at
Sun Jan 28 08:12:45 CET 2007

On Sunday 28 January 2007 17:45, Jonathon Suggs wrote:
> I am getting the following error when I try to build packages (tried
> several, same result).
> configure: error: C compiler cannot create executables
> I can give more details, but I've googled this quite a bit and can't
> seem to track down the underlying problem.  FYI, I can compile programs
> with gcc, so that isn't the issue.  I'm guessing the configure script
> must be looking in the wrong place for my compiler.
> Any thoughts/suggestions?  Thanks in advance!

Hi Jonathon,

I am using a fairly recently installed kubuntu distro.  As such, I found that 
many basic packages weren't installed when I first tried OE, but I was able 
to figure out what packages were missing by looking at the detailed error 
information.  In your case, it is probably in the config.log file.  If you 
can't see anything, send it over and I'll see if I can make sense of it.

FYI: Some of my issues were missing/incorrectly configured cpp, missing 
headers, and wrong gcc version (I've been playing with a few different 
targets).  Fortunately for me, ubuntu comes with easy package managements 
tools so it was a quick process to find and install the right stuff.

Have fun,


More information about the openmoko-devel mailing list