Help.. How to apply patch to BitBake recipe file?

John Seghers jseghers at
Sat Jun 23 01:15:21 CEST 2007

I am using the MokoMakefile.  I've tried to get the "make update" to use the
patch from bug #599 many different ways and can't seem to get it to work.

If I manually edit the target file, it will build the openmoko-devel-image,
but any time I "make update" it reverts to the problematic code.

I downloaded the patch file to "pulseaudio-bitbake-fix.patch" and placed
that in /home/moko/patches/openmoko-HEAD.  Then I created a series file
there containing:


The first four lines of the pulseaudio patch are:

Index: oe/packages/pulseaudio/
--- oe/packages/pulseaudio/	(revision 2207)
+++ oe/packages/pulseaudio/	(working copy)

This is referring to the file at
which is also the file at
since /home/moko/oe is a link to the deeper tree.

The beginning of silence-retrieved-revisions.patch contains:

 trunk/oe/classes/base.bbclass |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Index: openmoko/trunk/oe/classes/base.bbclass
+++ openmoko/trunk/oe/classes/base.bbclass

When I try to run "make update" however, it states it cannot find the file
to be patched.

I've tried appending " -p0" to the line in the series file to no effect.

I also tried "quilt import <patch file>" and it put the patch file and a
series file in /home/moko/patches but it did not get applied during "make

I also tried:
$ quilt new new-patch-name.patch
$ quilt edit <filename>
$ quilt refresh

This created a patch file in the /home/moko/patches directory, but with the
path name moko/oe/... and  Again, no effect on the execution
of "make update".

- John

Rod Whitby wrote:
> If you want to introduce patches into a MokoMakefile build, you can use
> quilt in the normal way.  The patches get stored in the patches
> directory, and these are not reverted (they are unapplied and then
> reapplied by quilt each time you do a "make update").

More information about the openmoko-devel mailing list