Sv: Mono on OpenMoko

Henryk Plötz henryk at
Tue Oct 30 02:49:45 CET 2007


Am Sun, 28 Oct 2007 10:01:47 +0100 schrieb Mikkel Meyer Andersen:

> "I haven't tried compiling on the Neo itself, but compiling on your
> computer and running the result on the Neo works great."
> I tried that too, and it didn't work either.

How did it fail? Did it also do the "Illegal instruction" (which as far
as I know nobody else reported yet) or did you rediscover which would lead to
"** ERROR **: file inssel.c: line 3673 (mono_burg_emit): should not be
reached" (maybe with different line number) and a stack trace.

I just tried to do exactly the same you did (e.g. compile your Main.cs
with gmcs on my Neo) and it just worked. Maybe your build is somehow
broken? Please try
which has mono and mono-gmcs already included and is the build that I
tested. (Actually it's a build of the svn version of mono, but that
shouldn't matter.)

Henryk Plötz
Grüße aus Berlin
~ Help Microsoft fight software piracy: Give Linux to a friend today! ~

More information about the openmoko-devel mailing list