make flash-qemu-local hangs

Stefan Winkler openmoko at
Sun Sep 23 00:37:16 CEST 2007

Oh man, I constantly seem to fail to build an openmoko development
environment :-(

I am trying to set up an environment (mainly to write apps for openmoko)
since 2 weeks now.

First I tried to build an x86 environment (see my earlier mail - didn't get
an answer :-(( )

Now I have tried to build an arm openoko-devel-image. That went well.
However, now I am trying to run it using qemu.
I did the normal qemu-local chain of make targets. But in the step
flash-qemu-local the script or qemu simply hangs.
It starts executing a few commands until it gets to:

gta...# setenv bootcmd '

and then ... nada. Does nothing more and times out after 300 secs.

I tried to run qemu manually and I also get through to the command prompt,
but after the first command it hangs, too.
I can only kill the qemu process.

Has somebody but experienced such a behaviour? Is there a solution to my

What do you recommend in order to start app hacking for OM? (Ok, I can just
write plain GTK+ and compile libmokoui x86-natively on my dev machine, but I
also want to see, how my app looks like on a neo... So any suggestions,
pointers, whatever to help me get started are very welcome...

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the openmoko-devel mailing list