problems with my first root filesystem

Ray Lehtiniemi rayl at
Sun Sep 23 02:05:02 CEST 2007

hi john

thanks for your reply, i'm just now getting a free moment to play with my moko 
again... :-(

On Monday 10 September 2007 02:02, John Lee wrote:

> You might want to test your toolchain first?  If the kernel cannot
> execute the binary inside rootfs it will hang just like this.
> cd moko/build
> . ../setup-env
> bitbake helloworld-image

i've tried that, and indeed i get the "Hello world!" message on the display, 
although not on the serial console.

> Oh by the way, have you put
> BUILD_ARCH = "x86_64" inside your local.conf?

yes, i did. i also tried binutils 2.18 and 2.17.50, both with identical 

i did some more digging with the debug board.  by single stepping using the 
JTAG telnet interface, i can see that the kernel is in a loop trying to send 
SIGSEGV to the process, but notices that it's the init process and therefore 
doesn't actually send it. it therefore hangs in a loop trying to deliver the 

my guess is that is segfaulting for some reason, since any static 
executable i pass to the kernel with init= seems to work okay, but even hello 
world will hang if it is dynamically linked. i'm not sure how to get at the 
user stack trace from kernel space to confirm that, however... 

any ideas on how to proceed?  is there an easy flag i can pass to force the 
rootfs to be statically linked?


More information about the openmoko-devel mailing list