GTA02 GSM firmware upgrade with FLUID (was Re: status of GSM firmware)

Werner Almesberger werner at
Sat Apr 26 01:22:32 CEST 2008

Jay Vaughan wrote:
> We could really use this for the GTA01 too.  How?

Hmm, you'd still need the FLUID executable and the firmware binary,
neither of which I think are available outside Openmoko ...

I think if you change the instructions as follows, you may get
something that works on GTA01:

- you may have to remove FLUID_FLOWCONTROL=h and -Oo

- remove the echo X >/sys/.../power_on commands in my description

- instead of "gpio b7=X", use
  echo X >/sys/bus/platform/devices/.../power_on

- change the sysfs names from *neo1973* to *gta01*

I haven't tried that, though. I'm uncertain about the
FLUID_FLOWCONTROL=h part, because that's just the opposite of what I
used on GTA01 a year ago.

Not sure what changed there - it's either the GSM firmware being more
picky or the kernel setting RTS to a different value when hardware
flow control is disabled.

In any case, experimenting would reveal what's right ;-)

Another small mystery is why GTA02 also needs AT at POFF. Unlike GTA01Bv4,
GTA02 can reset the GSM modem directly, yet it didn't respond to it.
(This worked in GTA01Bv3, which could also reset the GSM modem.)
Anyway, since AT at POFF gets the job done, that's a very minor itch for
me :)

- Werner

More information about the openmoko-devel mailing list