gta02a5 prototype #30 brief review

Daniel Willmann daniel at
Wed Feb 27 01:18:15 CET 2008

On Tue, 26 Feb 2008 21:41:03 +0100
Michael 'Mickey' Lauer <mickey at> wrote:

> * GPS module works ok, very impressive actually, we even got a fix
> inside the ICE (which has very thick windows).

have you tried with your's again? After the stellar performance in the
ICE I wanted to demonstrate that to Stefan during our train ride to
Nürnberg today, but I haven't got anything from the GPS yet other than
empty NMEA sentences:


And by now the Neo had a couple of hours to get anything from GPS.
Since the serial output stops completely when I echo 0 to the pwron
device node I don't think it's a power issue.
I don't know what I did the first time to get GPS working. Usually even
with bad reception it should at least get the time.

Okay, I just took out the battery while the Neo was on (this is a
GTA02A4 btw) and tried to push the GPS connector a little and it got
time and date almost immediately. It's still trying to get a fix, but
I'm now a couple hundred kilometers from where it would expect.

I don't know if the connector to for the internal GPS antenna was just
loosely connected on production or if it could indeed come loose during
day-to-day use, but we should look into that either way.

Daniel Willmann
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the openmoko-devel mailing list