Fwd: flashing gta02

Lorn Potter lpotter at trolltech.com
Tue Feb 26 21:44:58 CET 2008

Andy Green wrote:
> Hash: SHA1
> Somebody in the thread at some point said:
>> Basically reset the device with the button on the debug board, and hit
>> enter in your terminal emulator about 1 - 2 seconds after.  This should
>> get you the U-Boot "shell" prompt.
>>> problem is, hitting the AUX button does nothing, ttyACM0 never shows up,
>>> so I cant use dfu-util.
> Wah well it is ttyACM1 I believe on the host usually.  If these devices
> had a working NOR, powering on while holding down the AUX button should
> come up in an alternative, read-only U-Boot.

Nothing happens on these devices when hitting AUX + POWER. not any 
ttyACM* nor does it power up, or show uboot menu. When pushing the power 
button there is no splash screen, only white.

>>> I tried these instructions:
>>> http://wiki.openmoko.org/wiki/Neo1973_Debug_Board_v2/Unbricking
>>> using gta02v5
>>> but now it doesn't power on or boot at all (#37)
>>> :)
> Well we managed to change the behaviour :-O  I guess check the ttyACM1
> thing and confirm AUX held while power on is dead, and then you are into
> getting openOCD working to debrick.

Neither of these units (37 and 41) worked correctly in regards to AUX 
button and uboot.

 >> >> Debug board "seems" to flash uboot, but nothing is changed.
 >> >>
 >> >> When I run openocd, I get tons of these:
 >> >>
 >> >> Debug:   embeddedice.c:220 embeddedice_read_reg_w_check(): 4
 >> >> Debug:   embeddedice.c:220 embeddedice_read_reg_w_check(): 1

Just a guess, but these seem to me, to be similar to the crap coming 
through /dev/input/event0 (AUX button) when the  OS is up and running. 
Perhaps all this crud is disabling the AUX button.

 > OpenOCD is super sensitive to the fdti serial library version you use.
 > V 0.8 IIRC worked for me and nothing else did.

.8 didn't work at all for me, so I used the latest .10 or something, 
which at least got me connecting using openocd.

Lorn 'ljp' Potter
Software Engineer, Systems Group, MES, Trolltech

More information about the openmoko-kernel mailing list