usb connection crashes Windows

Cédric Berger cedric.berger74 at
Mon Jan 19 22:34:57 CET 2009

On Mon, Jan 19, 2009 at 22:22, Andy Green <andy at> wrote:
> Hash: SHA1
> Wild guess is USB Ethernet / RNDIS changes in the kernel... another way
> it could conceivably do bad things is if somehow 1A charging mode was
> enabled, and it's crashing the PC, but I doubt that's it.

Yes phone trying to pull too much power was my first guess for such a
brutal reboot...
But when connected on another distro via ssh, I can force 1A charge
and the PC does not complain at all (battery current_power is then
about 780mA, plus current to run the phone...)

> It hasn't being generally crashing Linux machines, I guess it's a bug in
> the driver on XP side somewhere.
probably... but I have tried to remove driver... "tried" because I
cannot be sure... usually it explicitly appeared when connected...

I had this adb driver installed, and also I had before replaced it by
the "classic" neo windows driver (also not functional, but at least I
could charge my phone).
What is the exact status of my PC now I am not sure...
I will have to try on the PC of one of my collegues who have about the
same hardware :-p !

More information about the openmoko-kernel mailing list