trying Qi

Andy Green andy at
Fri Jan 30 13:07:51 CET 2009

Hash: SHA1

Somebody in the thread at some point said:
| Thanks for your answers
| On Fri, Jan 30, 2009 at 12:47, Andy Green <andy at> wrote:
|> | - via Aux button to swap the booting partition, can I force NAND boot
|> | ? (with the version I tried, I did not manage to do this)
|> If it doesn't find a kernel it likes from SD Card, it will fall back to
|> trying to boot one from NAND anyway.
| Yes, it does indeed (I tried without the SD card), but I would like to
| choose where I want to boot from.
| Pressing Aux to skip partition would be ok, but is skipping my 3 SD
| partitions so that it tries NAND  possible ?

Well you only need to skip the ones with ext2 / 3 and
/boot/uImage-GTA02.bin in them, I guess there is a limited number of
partitions on your card meeting that description.  If you press AUX
while it is loading the kernel, it will skip that and go on to the next

| (Now I'll try to make bootable my 2nd partition (currently is the
| 3rd), to try if I can choose between 2nd and 3rd at least...)

FWIW Qi ignores the boot flag in the partition table, not sure if you
mean that or just adding /boot/uImage-gta02.bin

| Next step will of course be a partition with a menu to choose from
| where to boot, but simple button to choose between my SD partitions
| and NAND would be good...

AUX will do the skip action as I say above.  But you have the right
idea, anything more complex should be handled by Linux.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list