"opkg upgrade" breaks USB networking: g_ether module missing

Andy Green andy at openmoko.com
Fri Aug 1 09:03:17 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| Yes, could be this as I am seeing the same messages in the log.  I did
| update uboot on the weekend (which is when I got the device).
| A wall charger worked normally, its just usb charging (tried a laptop
| and a desktop) thats the problem.

Well it sounds a bit out of place to say it, but: great.  At least we
understand what's happening.

A wall charger doesn't try to talk with the device over USB, it is
recognized by a magic resistor on the USB ID pin, that's why it works
but host charging didn't.

I made patches to reduce the probability of this from 50:50 to ~10% and
just sent them out, I didn't find how to eliminate it yet.

| Which uboot is "safe"?

I'm not sure.  I suspect older U-Boot had lower probability of making
the same problem since we had no idea this was happening until now, and
some of the fixes I added would have been needed on older versions too.
~ best bet is to update to tomorrow's U-Boot and we'll try to remove the
remaining chance of the problem in the meanwhile.


- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the support mailing list