FSO Wifi - can ping but cannot download

Andy Green andy at openmoko.com
Mon Aug 4 13:18:45 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| Andy Green escreveu:
|> Somebody in the thread at some point said:
|> | I've configured WiFi on a fresh FSO image the same way I had on a
|> | image--by creating a wpa_supplicant.conf file and editing
|> | /etc/network/interfaces.  This configuration worked on the 2008.2 image
|> | but when I try implementing it on an FSO image, I cannot download
|> | anything.  I can ping sites and when using wget, I can connect to them,
|> | but downloading never commences.  It's not a DNS issue because ping and
|> | wget seem to be able to resolve correctly.  Any thoughts?
|> Sounds specific to tcp transport, ping is ICMP and DNS usually UDP.
|> Maybe connect to a local Linux box and run tcpdump on there to study
|> what it sees from the connection action.
| No, it's not "ping and DNS do not use TCP". It's "ping and DNS and TCP
| SYN are small packets, data transfer is large packets", i.e. PMTU
| blackhole. I've seen that thing happen way too many times, and the
| workaround is almost always a MSS clamp (which is an ugly but
| unfortunately necessary hack).

Well, he says it worked on some other image.

The guy can test this by seeing if he has any bulk transfer with local
machines on his side of his router.

He can also mess with his ping payload size and confirm if that controls
the issue...

# ping -s 4096
PING ( 4096(4124) bytes of data.
4104 bytes from icmp_seq=1 ttl=64 time=5.36 ms

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the support mailing list