FSO Wifi - can ping but cannot download

Dylan Semler dylan.semler at gmail.com
Tue Aug 5 07:46:32 CEST 2008

On Mon, Aug 4, 2008 at 5:46 AM, Cesar Eduardo Barros <cesarb at cesarb.net>wrote:

> Andy Green escreveu:
> > Sounds specific to tcp transport, ping is ICMP and DNS usually UDP.
> > Maybe connect to a local Linux box and run tcpdump on there to study
> > what it sees from the connection action.
> No, it's not "ping and DNS do not use TCP". It's "ping and DNS and TCP
> SYN are small packets, data transfer is large packets", i.e. PMTU
> blackhole. I've seen that thing happen way too many times, and the
> workaround is almost always a MSS clamp (which is an ugly but
> unfortunately necessary hack).
Well internet is working now, I'm still not sure what was wrong though.  I
got a bit of help about MSS clamp[1] and tried the following commands from
my router:

# nvram set ppp_mtu=1492
# nvram commit
# reboot

upon reboot of the router I verified that it worked:
# nvram show | grep mtu
size: 25395 bytes (7373 left)

but internet still didn't work.  I then started stabbing in the dark, trying
nvram set wan_mtu=1492 and nvram set mtu_enable=1.  Those changes didn't
seem to take hold (according to nvram show) so I set them back to 1500 and 0
and rebooted.  When the router came back online the internet was working on
my Freerunner.  I then set ppp_mtu=1500 to verify that that was the issue,
and my Freerunner still worked.  So now I'm not hacking an MSS clamp and the
internet seems to be working.  Maybe the router just needed to be restarted
a few times.

Thanks for all of your help.

[1] http://forum.openwrt.org/viewtopic.php?id=5662

Type faster. Use Dvorak:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/support/attachments/20080805/45949e28/attachment.htm 

More information about the support mailing list