Trouble flashing 2008.08

Zack Mollusc zmollusc at
Thu Aug 7 08:10:33 CEST 2008

Mike MacHenry wrote:
> I'm using a neo freerunner and I am having a rather difficult time
> figuring out how to flash 2008.08 image that I was take to from the
> download link. From reading the wiki I've figured out
> that I need a kernel image and a rootfs image. Then I am supposed to
> boot into NOR flash mode and run the following two commands:
> dfu-util -a kernel -R -D /path/to/uImage
> dfu-util -a rootfs -R -D rootfs_filename.jffs2
> The problem is I can't figure out which of roughly 50 files from the
> this list I should download.
> I tried several combinations of files that ended in jffs2 for the
> rootfs file and files that had "gta02" and ended in .bin for the
> kernel image. Mostly the result I get is the openmoko splash screen
> when the device starts staying on the screen forever. I once got the
> machine to boot into a running distro but the machine was incredibly
> unreliable. Clicking on an icon gave a totally black screen, there
> were no buttons at the bottom of the app but it looked like there
> should be. Pressing the power button had no effect either.
> I think I'm just downloading the wrong images. I used qtopia the other
> day and it worked fine so my hardware is not busted.
> _______________________________________________
> support mailing list
> support at

Hi, not being an expert, i installed the root filesystem
(Openmoko-Freerunner-20080424-om-gta02.rootfs.jffs2) and flashed the
kernel (uImage-2.6.24+git20080424-om-gta02.bin) when I had got mine
cocked up. This took it back to 'as received' condition, and then i opkd
update, upgrade once i got the usb networking going again.

More information about the support mailing list