Todays 2008.08 Bug list

Craig Woodward woody at
Sat Aug 9 01:35:09 CEST 2008

Ok, so here are just a few things I've found working with the current image today:

On the plus side:

The new SMS message app is MUCH improved from 2007.* and qt. Very nice job on that part!  Almost makes the phone worth using as a phone now...

Contact Manager has the same problem as the system clock (bottom 2 buttons are not usable, which is a huge issue).

Dialer: I like the look, but again, those pesky bottom buttons don't work...

Diversity is nice... but without wifi working... its hard to get a fix on gps while in the building, tethered to usb, which is my only network option right now. :P  BUT It's bottom buttons work...  Is that a soft-key system I see down there?

Things that are busted:

o Nothing connects w/ wifi.  I've tried open, WEP, WPA and WPA2, with simple passwords, and connman can't connect to anything out of box.  It appears to no even get eth0 setup, yet alone the sub system for wpa.

o Anything that has bottom buttons  (like the system clock, dialer, etc), the buttons are totally inaccessible.  When you hit either, the whole bottom bar goes out and shows the background.  The main window shows forward, but the focus is on enlightenment, so you have to hit the app window again before removing for it to work.  (Is there s soft-key bar in that area too? Could that be the issue?)

o The keyboard is now stuck in predictive mode.  The switch symbol is gone, and there appears to be no way to get it back that I can find.  Great for texting, bad for terminals.

o The config (wrench) icon is gone from the top and hidden menu, meaning there's no UI method at start up for changing settings (like adding the wrench, or BT/wifi symbols) to the header.

o When the header does have things turned on, and anything reaches the mid point of the bar, you can no longer pull down the bar with the arrow, making it impossible to remove tasks.

o Why was the close task function removed from power-button-tap?  And why isn't the Aux button mapped on the window manager to enter the config menu any more?  I'm sure there's a good reason, but it's existing behavior people have come to expect.

o There's still no way to cleanly shutdown 2008.8.  Running shutdown gets it stuck in runlevel 5 without more processes.  Pressing the power button does nothing.  Holding it for 10 kills power, but also kills the fs sometimes too. :P

o None of the bluetooth add-ons are working any more... /dev/rfcomm0 seems to not exist?  And obexftpd and opd return an "error -94/0"  and can't connect to the bluetooth local side.  (Though obexftp starts showing as a registered service once run... but the daemon has exited, so it doesn't connect... sigh!)

That's all I've found in the 10 minutes I've played with it, so. :)

More information about the support mailing list