remoko bluetooth problem

lists at lists at
Wed Aug 13 19:41:47 CEST 2008

I'm trying to test out the remoko app Valerio wrote.  I've installed both the  
remoko and remokoserver packages.  However, I can't seem to connect to it 
from my linux box.  If I run remoko from the terminal app so that I can see 
the console output, I get the following after I run hidd --connect <FR bt 

dbus.Array([], signature=dbus.Signature('s'))
ERROR: Bluetooth is off

I've tracked that down to coming from the last part of where 
self.remoko.adapter.ListConnection() seems to fail.  Interestingly, running

dbus-send --system --type=method_call --print-reply --dest=org.bluez /org/bluez/hci0 

returns an empty array, however

hcitool con

shows a connection to my linux box.

I'm using 2007.2 and have updated all packages today (Aug 13th).

In case it's related at all, running hidd --search on my linux box after 
launching remoko on my FR doesn't find anything.

Any ideas why the call to ListConnections returns an empty array?


More information about the support mailing list