How to compile assassin?

Rorschach r0rschach at
Fri Aug 15 11:44:19 CEST 2008

On Fri, 15 Aug 2008 07:24:49 +0930
Rod Whitby <rod at> wrote:

> Most (if not all) images and packages are cross-compiled on an x86 host.

Okay I installed now the toolchain on my system (ubuntu hardy) and tried to compile it there. Now the autogen-part works but configure aborts with an error:

checking pkg-config is at least version 0.9.0... yes
checking for EDJE... configure: error: Package requirements (edje >= 0.5.0) were not met:

No package 'edje' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EDJE_CFLAGS
and EDJE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

FATAL: oe_runconf failed

So it says edje is missing but I have installed: libedje-bin, libedje-dev and libedje0 . I guess it can't find it? But it's all in a standard-folder:

$ dpkg -L libedje0
$ dpkg -L libedje-dev

I also tried setting PKG_CONFIG_PATH to /usr/lib/pkgconfig or /usr/lib/pkgconfig/edje.pc but with no success :( Also setting EDJE_LIBS to /usr/lib/ has no impact. Always the same error message. Any idea?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the support mailing list