Testing WIFI and GPS hardware

Chris Jenks chris at jenks.us
Fri Aug 15 20:09:00 CEST 2008

   Although it looks like it will be some time before all the hardware in 
the Freerunner becomes completely usable, I would at least like to be able 
to verify that the hardware I received works correctly. I have no idea if 
there is a time limit for having this unit repaired or replaced if it was 
defective when I received it.
   I am pleased that the GSM worked right away for both sending and 
receiving calls. The two other main systems I would like to test are WIFI 
and GPS, but these didn't seem to work immediately.
   Under both 2007.2 and 2008.8, when I issue the command "ifup eth0" I 
always get:

root at om-gta02:~# ifup eth0
udhcpc (v1.9.1) started
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with return code 1
Sending discover...
Sending discover...
Sending discover...
No lease, failing

even though there is an unsecured WAP nearby, which gives a signal 
strength of 27/94 according to the "iwlist eth0 scan" command. Other 
people have reported that WIFI to unsecured WAPs worked out-of-the-box, so 
I wonder why mine doesn't.
   Although I couldn't get WIFI to work under the "Locations" graphical 
application (which says "Searching for your location" and then "ERROR: 
Unable to locate a fix" when I turn on GPS), I haven't heard of much 
success from others either.
   It would be nice if the wiki had some simple procedures for testing the 
Freerunner to verify that the hardware works as it should, so people know 
when to send their unit in for service or when to spend more time trying 
to get software working.



More information about the support mailing list