r(qtopia - kernel panic)

Edgar D' Souza edgar.b.dsouza at gmail.com
Tue Aug 26 11:40:32 CEST 2008

On Tue, Aug 26, 2008 at 1:40 PM, syed yaqoob ali <yaqoobali007 at gmail.com> wrote:
> Hi,
>   I have downloaded qtopia  and  after preparing sdcard ,installed the
> kernel and file system in the respective partitions.But when i m trying
> to boot thorough sdcard in qtopia . During kernel execution kernel is
> panicking .I am getting the following error.
> " Warning : unable to  open an initial console    "
> "  Kernel panic - not syncing : no init found .try passing init= option
> to kernel"

Have you tried with Shakthi Kannan's procedure:
for which I was very grateful, since the procedure otherwise seemed a
bit intimidating.
Of course, step 6 assumes that the SD card has at some point gotten
out of the card reader on your host PC and back into the (booted and
USB networking-connected) phone... but you can also adapt the commands
to untar the image onto the microSD card while it is still in your
card reader on your host PC, and still get the same results (I did it
that way). Actually, you could probably just pipe the tar stdout
output from the /dev/mtdblock0 mountpoint to another tar process that
untarred it onto the ext2 partition on the microSD card in your card
reader, and it should still work. However, despite refinements, I
found that Shakthi's method worked very well for me.

A small glitch I found with Qtopia on the SD card, though, was that
practically all the filesystem-related functionality (music player,
etc etc) only seemed to look at the first, VFAT partition... even
though apparently running off the second, ext2 filesystem. SSHing into
the phone revealed that /etc/fstab did not have a mount line for the
second partition (??!) but despite adding that and rebooting the
phone, I was unable to get Qtopia to "see" my music on the second
partition. Still haven't figured that one out (though I don't get too
much time to play with the phone) :-(


More information about the support mailing list