suspend/resume and Debian on SD card

Cédric Berger cedric.berger74 at
Thu Aug 28 20:22:39 CEST 2008

On Thu, Aug 28, 2008 at 16:10, Simon Matthews <s.matthews at> wrote:

> Have you tried my workaround
>        This is working reliably for me. I would be interested to know
>        if anyone else has tried this and whether it works for them as
>        well
>        If having the SD clock on all the time
>        is causing problems with the GPS you could turn it on before the
>        suspend
>        (part of a suspend shell script maybe) and turn it off using
>        echo 0 > /sys/module/glamo_mci/parameters/sd_idleclk
>        after a resume.
>        I have a simple script to do the suspend
>        echo 1 > /sys/module/glamo_mci/parameters/sd_idleclk
>        dd if=/dev/mmcblk0 of=/dev/null count=1
>        apm -s

I did the echo 1 > /sys/module/glamo_mci/parameters/sd_idleclk
 and  I am now able to suspend/resume (tried with Qtopia booted from SD 8GB)
Before that it always failed (tried with qtopia / 2007/02 / 2008/8
...), with often lost partion table.

Will be ok if we can have a script on suspend/resume, or maybe if the
kernel modification on sd_idleclk was patched to better handle on

why was the  "dd if=/dev/mmcblk0 of=/dev/null count=1" for ?    I
didn't do that.... (I had partition table saved to disk before trying
but I think I rebooted after)

Thanks a lot ! I finally can use my 8gb card... (well.. I hope it will
continue to work)

More information about the support mailing list