GPS Problem (maybe antenna?)

robins r.seidel at
Sun Aug 31 18:44:30 CEST 2008

Hi List, hi Sebastian,

I was wondering if you know, how long a position fix should take under
normal conditions. I sometimes need more than 30 minutes, but also had the
lucky chance of getting one under three minutes. 
So do you have any idea what times should be expected from the freerunner.
Could you please keep us up date on how you examined yours, so we can do the
same if we need to.

Thanks and best regards


Sebastian M. wrote:
> Hi list,
> I have some gps problems on my Freerunner, but it seems like they do  
> not origin from bad soldering of the internal gps connector (removed  
> the plug with a small watchmakers screwdriver and examined it with my  
> eyes [don't have much more at my dorm] and it seems to be ok (inner  
> pin is not malformed, all solderings *look* alright - but could still  
> be bad)).
> My setup is: Om2008.8 with default sources plus angstrom distribution  
> source. gpsd is installed and configured (/etc/default/gpsd stuff),  
> agps is set up as well, I use a script /usr/bin/agps which contains:
>> agps-onlinec -c full -u "xxxmailxxx" -k "xxxpassxxx" -la 49.362960  
>> -lo 7.773482 -al 400 -p 500.00
> Those coordinates are from Google Maps, verified at Wikipedia (as well  
> as the altitude, 400m). Accuracy is 500 km (if I'm not wrong!).
> I do all my testing with the Freerunner pointing towards the sky (like  
> OpenMoko Staff did for their measurment) and standing on the edge of  
> my balcony (50% sky visible).
> Then I run those commands by ssh over WiFi (Mokos IP is
> On Moko: /etc/init.d/gpsd start
> On Laptop: xpgs
> This shows the current GPS data on my laptop - which is nothing (not  
> even seeing a satellite) and does not change even after 5 minutes  
> (remember: no SD Card inserted).
> I once had a usb GPS device which saw satellites in the very same  
> position at an instant and took about 40 seconds to get a fix.
> Now I run agps:
> root at om-gta02:~# agps
> connect to
> aid data 2664 bytes received
> aid data raw written ok
> This correctly "injects" satellite data into the gps as xgps now shows  
> some satellites with a Signal-to-Noise Ratio of 0, but the gps still  
> does not see any of them (and judging from the plotted data and that I  
> know where north is it should be able to see at least 5 satellites).
> Letting the MoKo run for 40 minutes doesn't make it any better.
> I tried this with Om2007.2 (on SD), Om2008.8 (on Flash), FSO Milestone  
> 2 Stable (on SD), FSO Milestone 12. August from  
> (on SD).
> All systems were "opkg update && opkg upgrade"-d, apgs configured and  
> gpsd configured.
> Using something else than xgps (tangogps on moko, agpsui on moko,  
> gpspipe -r) shows the same results.
> Well, gpspipe shows those "I have no clue where I  
> am"-position-datasets and after using agps it shows the injected  
> satellites => Software should be alright alright.
> This leaves either the internal connector or the antenna itself.
> Because the connector *seems* to be ok I think there could be also a  
> problem with the antenna. The soldering one can see after removing the  
> rearcover looks not very good, but I can't measure any of them right  
> now.
> As soon as I get to my parents (propably on monday) I can use my  
> fathers equipment (multimeter for solderings, a nice high frequency  
> analyzers for the antenna :-D) and knowledge to search for the  
> problem, but in case someone has any hints and/or ideas what I could  
> try at my dorm (not much hardware here besides some screwdrivers, a  
> linux laptop and a wireless network ;-)) I would happy to try that.
> Any help would be appreciated.
> Good night, Sebastian
> (I hope my english is understandable - I'm quite tired because I have  
> been working on this the last 7 hours, and before that was at my  
> system admin job for about 6 hours and I am somewhat addicted to my  
> Freerunner so I got not much sleep last night :-D)
> -- 
> Sebastian M.
> Student of Computer Science at the University of Kaiserslautern.
> _______________________________________________
> support mailing list
> support at

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list