Debian on the FreeRunner -- a few questions/solutions

Timo Juhani Lindfors timo.lindfors at
Mon Aug 25 08:01:27 CEST 2008

Fox Mulder <Quakeman1 at> writes:
> else:
>     self.timeouts = { \
>                     "IDLE": 1,
>                     "IDLE_DIM": 2,
>                     "IDLE_PRELOCK": 3,
>                     "LOCK": 4,
>                     "SUSPEND": 20, \
>                     }
> But i don't really know if these numbers are minutes or something else.

line 119 says they are seconds:

self.timeout = gobject.timeout_add_seconds( self.timeouts["IDLE"], self.onIDLE )

> But after installing the new compiled package the result is not exactly
> what i hoped for. Within xfce and no thone running the behaviour is the
> same as before. Ahen i start zhone the backlight dims after ~25s and
> gets complete dark and locks after ~15s more.

Line 93 reads

# override default timeouts with configuration (if set)                                                                                              
        for key in self.timeouts:
            self.timeouts[key] = config.getInt( MODULE_NAME, key.lower(), self.timeouts[key] )

so maybe your frameworkd.conf overrides these? I'm sorry for not
reading the whole source code when I suggested you to change it.

> This didn't work at all. When i try to compile it with "apt-get --build
> source zhone" i get an error message that some archives couldn't be
> downloaded. I only got zhone_0-git20080809.orig.tar.gz and it also wants
> the dsc and diff file.

Can you try again? I just did aptitude update with

deb-src unstable main
deb-src sid main
deb-src experimental main

in sources.list and can get the sources just fine:

$ apt-get source zhone
Reading package lists... Done
Building dependency tree
Reading state information... Done
Need to get 918kB of source archives.
Get:1 unstable/main zhone 0-git20080809-4 (dsc) [1215B]
Get:2 unstable/main zhone 0-git20080809-4 (tar) [914kB]
Get:3 unstable/main zhone 0-git20080809-4 (diff) [2779B]
Fetched 918kB in 1s (658kB/s)
dpkg-source: extracting zhone in zhone-0-git20080809
dpkg-source: info: unpacking zhone_0-git20080809.orig.tar.gz
dpkg-source: info: applying zhone_0-git20080809-4.diff.gz

> Is there a way to change this setting for xfce?

At the moment if you don't run zhone then brigthness won't change
depending on idle status. You can always send dbus suitable messages
yourself to control the brightness from xfce. I can lookup the
required command to do this if you can't figure it out (but I'm bit
busy right now).

More information about the community mailing list