Getting rid of echo for callers.

Daniel Selinger slite at
Fri Aug 29 03:21:20 CEST 2008

I've experimented with alsa settings for the last 3 hours and want to
share my experience now.
I was doing this on top of QTopia 4.3.2 and it's default
gsmhandset.state file.

The relevant mixer settings i found to, in my case completely eliminate
the echo for the caller, are the following 
(Setting -> Old Val -> New Val):
'Speaker Playback Volume' 127 -> 100
'Mono Playback Volume' 103 -> 85
'Mono Sidetone Playback Volume' 2 -> 0
'Bypass Playback Volume' 7 -> 5
'Mic2 Capture Volume' 0 -> 3

This settings removes the echo for the other person completely, at
least for my hardware. I didn't hear any buzz either on my final
testcalls, could be luck.

The last thing remaining, is a bit of selfecho, which was also
reduced with this settings but not away. (was as loud as the echo on the
other phone with qtopia default gsmhandset.state). But didn't get away
completely, but the other side doesn't hear anything of it.

I also attach my gsmhandset.state for the case other distros have a
different default file. (I was to lazy to check against .state of every

If anyone has a configuration where he doesn't hear echo of himself
talking at all, please please please provide me with an .state file, to
check which controls are responsible for that!

rgds Daniel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gsmhandset.state
Type: application/octet-stream
Size: 17261 bytes
Desc: not available
Url : 

More information about the community mailing list