Intone 0.60 Almost Stable ;-)

c_c cchandel at
Wed Jul 22 13:41:46 CEST 2009


Staley, Daniel L wrote:
> Alright....I figured out how to get intone to work with my bluetooth
> headset!  I have to start a song, pause it and then start it again...but
> thats alright.
  Great - nice to know the scancodes are the same :-)

Staley, Daniel L wrote:
> All my keys worked great  (same key codes as other poster)
> Occasionally I have problems with the play/pause...but it doesnt look like
> mine is from the code being sent twice (intone doesnt report it twice
> anyway).
  Intone rejects a second keypress if it happens within 250ms of the first
one - but it doesn't say so. I'll print that out too - just so it's clear.

Staley, Daniel L wrote:
> It looks to me like the error occurs after I used the previous key, and
> then tried the play/pause key.  When that happened intone gui shows on the
> play/pause toggle button a play button (when it should be a pause)
> and just keeps on playing the song.
  Hmm. I wonder why? I'll take a look.

Staley, Daniel L wrote:
> I got time outputs of:  (not sure what these are...)
> time - 1248187227.222462
> time - 3.214989
> time - 115.908660
  These figures are the time between '2 successive play/pause' key presses.
The large figure is for the first press.
  It seems like your headset sends only one press. Can you play around with
the play button to see what the problem could be?

Staley, Daniel L wrote:
> I ran mplayer from the command line and saw that mplayer actually outputs:
> [AO_ALSA] Trying to reset soundcard.
> [AO_ALSA] Write error: Broken pipe 16.4%  (or whatever percent of the song
> its on)
> Hope this helps! 
  Yes! It does. That's exactly what I was looking for - some error from
mplayer that tells me how its handling the break in sound output. I think I
should be able to handle these breaks now.
Thanks again for all your inputs.
View this message in context:
Sent from the Openmoko Community mailing list archive at

More information about the community mailing list