Installing v35

Liz edodd at
Tue Jan 31 05:39:59 CET 2012

On Tue, 31 Jan 2012 09:18:27 +1100
Liz <edodd at> wrote:

> On Mon, 31 Oct 2011 02:25:54 +1100
> Philip Rhoades <phil at> wrote:
> > I used:
> > 
> > dfu-util -a kernel -R -D uImage-v35.bin
> > dfu-util -a rootfs -R -D qtmoko-debian-v35.ubi
> > dfu-util -a u-boot -R -D qi-v35.udfu
> I've got a Freerunner with no working NAND boot (ie pressing the Power
> key does nothing).
> I've just tried to put on v35 with those commands but still there is
> no response from the Power key.
> Booting from NOR results in 
> CRC error bad data Checksum
> can't get kernel image
> I've tried a few installs of the kernel whose md5sum is
> 907917848c8437f8f4126b8a971b06da  uImage-v35.bin
> any help available?
> Liz

I tried flashing the NAND with a few other bootloaders.
What I have now is that pushing the Power key gives me NOR boot.
I can boot an old Om2008 I've got here
but after that I lost touchscreen input again
Original QT was working last night - but I don't have a copy of that
kernel and image any more.

NOR boot can only boot off SD card if FAT + ext2
and so it can't read the debian on ext3 that I made.

What options do I have to get qtmoko working?

More information about the community mailing list