Bad Customer support from about a Broken Battery

ankostis ankostis at
Wed Dec 10 14:44:28 CET 2008


as a last resort i'm reporting publicly my problems regarding a
broken-on-arrival battery from after i had ordered from
them OpenMoko's FR, on August 2008.

I reported my problematic battery as soon as i got my hands on it, on
late August-September on  the following MLs:
[1]: New battery semi-charged but not charging, is protection-circuit broken?
[2]: Will a full discharge reset the battery-protection-circuit's CPU?

I also communicated the problem with truebox and after running a
script they provided me with,
they accepted to replace my battery.

Ever since, i sent many mails and received half as many replies,
but no battery arrived.

Once they claimed me that they had sent a battery but it was somehow
never delivered to me.
I asked them for some tracking id but never replied back about it.

I'm including just a small fraction of my mail concerning this
incident, below, as context.

Currently, i'm still using my FR utilizing a Nokia-BL batter with
800mh, enough for just some hours of continuous operation.
I would really appreciate any advice on how to procceed from now on.

  Kostis Anagnostopoulos

PS: I live in Greece, Crete, so i suppose that makes me an "endangered
species",  since i have not heard any other Moko-owner from Greece.


---------- Forwarded message ----------

From: ankostis <ankostis at>
Date: Fri, Oct 31, 2008 at 2:41 PM
Subject: Re: [Fwd: Re: Problem with new battery]
To: Rob Wood <rob at>, customerservices at


I bought an FreeRunner OpenMoko device from TrueBox at the mid-of July
and i received it on August 2008,
but it had a broken battery.
I described the problem initially at the openmoko mailling-lists:

I reported the problem to TrueBox back on September the 1st,
and then i was told by Rob Wood that you will send me a replacement battery.
(i provide some context from older emails, below)

I'm still waiting for my replacement-battery to arrive.
The last mail i sent 3 days ago,went un-answered.

Can you please give me an update on this item?

 Kostis Anagnostopoulos

On Tue, Sep 2, 2008 at 12:36 PM, Rob Wood <rob at> wrote:
> Hi Kostis,
> It does look like there is a problem with your battery. We will post you a
> replacement.
> Best regards,
> Rob

On Thu, Oct 16, 2008 at 10:48 AM, Rob Wood <rob at> wrote:
> A second one was sent when we "talked" last time. I guess it has not
> arrived?
> Cheers
> Rob
> On Thu, Oct 2, 2008 at 1:33 PM, Rob Wood <rob at> wrote:
> We will ship you another battery. Can you just confirm your FULL address in
> the format that has the best chance of it being delivered:)

On Wed, Oct 29, 2008 at 8:00 PM, ankostis <ankostis at> wrote:
> Hi, Rob,
> i still have not received the battery, and it's been almost a month
> since you send it.
> It ussualy takes (approximately) a week for a normal package to arrive
> from UK to Greece by Royal Mail.
> Can you check it one more time, please,
> Greetings,
>  Kostis

More information about the community mailing list