Charging/powersupply trouble

Finn-Arne Johansen faj at
Wed Jan 7 09:03:54 CET 2009

I received my FR a few days before Xmas, and was planning on playing
with it during the holidays. I finnaly made it to work after a couple of
days (or more like a week), but now it has failed me again, and I'm
seeking advise on what to do/test, or if I should return it.

First some info on the initial trouble:
I Had some trouble to get it to recognise my simcard, and also my
provider had some trouble registrating the simcard correctly. First I
tried the one I have in my 3G usb-dongle, and it registered most some
times, but since this is a 3G-only card, I was not able to call with it.
I was able to send and receive SMS's though.
Then I got the new card, which should use the same phone number as my
main-card (we call it twin-card?). First it was registered with my
number on incomming calls/sms, but another persons number on outgoing
connections. Then it was not working, and finally it was set up
correctly. That is - the simcard was correctly set up, I was able to use
it as my main number on both incomming an outgoing connections/calls.
This was with my other phone. After my provider set the simcard up
correctly, I was able to uses it normally in another phone. But not in
the FR. It failed to register. I ended up upgrading the GSM firmware,
and then the SIM-card registered nicely, and I was able to play with the
FR as a normal phone, using qtExtended. I Even used it as my main phone,
leaving my SE-P1i shut down at home.
This was for 3-4 days. It mostly was charging over night connected to my
laptop, and was used during day.
Then, on Friday (the 2nd), it was low on battery. I connected t to be
charged, but for some reason, it was not able to take charge. This was
using a USB-cable. I connected it to the power-supply, but I was not
able to wake it up. Then I went for the office to get the 2nd battery (I
ordered 2 extra batteries...), and replaced the discharged, and it
powered up, but I was not able to "hot-swap" the batteries. OK, Lets
leave the new one in, and let it charge over night, I thought. Next
morning the FR was dead again.
Then I read something about it having problems with string to discharge
after the charging had completed, but found it strange.
Then reading further, I read something about not charging until you
disconnect and reconnect the usb-cable. But that didn't help either.
Back at the office on Monday I found the 3rd (and last) GTA02 battery
that I got with the phone, and connected it. the device booted, and I
saw that it worked, but no red light in the AUX-button. I think I got
the red light to lit up, but after a while the phone suspended, and
after that it was dead again.
OK, sp now I have 3 dead GTA02 batteries. I found that my RoyalTek
bluetooth GPS device uses somewhat similar batteries, same connectors,
same polarity and voltage, but a bit thinner, and with the notches on
the battery on the "other side". So I cant charge the GTA02 in the GPS,
but I can use the 680mAh battery from the GPS in the FR.
With the battery from the GSP, I'm able to boot and use the FR, but I'm
not able to hot-swap the batteries. I've tried all the tips I've found
on the wiki, trying to boot using nand/nor u-boot, powering the device
while holding the aux-button and I dont know what. The only way I'm able
to boot the FR, is using a battery that is charged somewhat. When teh
device is booted, I've checked the charger-type from
/sys/class/i2c-adapter ..../charger_type
and also curlim_usb (or what's it called) and it seems like it's
charging with either 500mA, or 1A. I've ordered a non-nokia
BL-5C-charger (and battery), but it will take some days for it to
arrive. Right now I'm considering 3 options:
1: Returning the FR, and hope to get a replacement
2: Placing the GTA02-battery in my FR, then add some wires and boot the
   device using the GPS-battery (I first have to charge the GPSbattery)
3: opening the device, and try to see if there are som bad soldering,
   some capacitor that's fried, or something else.

But first I turn to you. Is there any test that I can do, any tips on
things that I'm not been able to find via Google.

or a single list with try
 method A
 method B
or ...

And then I can reply
 method A - checked
 method B - checked


Sorry for the kind of long first-mailing to the list, Hope you can stand
reading it, and have some advise for me...

Oh - last info:
booting from uboot (nand: power - aux - menu), checking
   neo1973 charger status
I got play_only_mode
I upgraded the u-boot, and then I got

I was not able to change the charger mode using
 neo1973 charger fast/autofast
but I was told on IRC that this was not possible using uboot.

I am however able to change the charging current using  sysfs when the
device is booted with the GPS-battery.

My plan for today is to charge the GPS-battery slightly, then boot the
FR, and see if it's able to work the rest of the day with the charger
connected (or usb-cable). I Just have to disbale the suspend-mode, cause
that's when it died on my on monday...

// faj

More information about the hardware mailing list